Snowflake execute (select SQL)- Capture results

We are using Snowflake execute snap to run a metadata query against Snowflake and using the output of it in mapper snap.
Snowflake execute snap- preview data shows expected data from sql. In the mapper snap, input schema is not available for snowflake execute-select sql.
Is there a way to capture/use the results from snowflake execute-sql(select) and use it in mapper or subsequent snaps.


HI @smahla,

I see that between your snowflak snap and mapper snap the connection is not added what I mean is you need to connect the two snaps by clicking on the circle between the snaps so it looks like the circle between the mapper and the for each snap.

So click on the white part between the to snaps to connect them



Thank you Jen.
Yes, I could see the output of Snowflake-execute(Select SQL) in Mapper input schema now.

Had tried with Insert SQL in snowflake-execute and it worked fine but when replaced INSERT with Select SQL it was not showing earlier.

FOREACH snap, can we read the output of mapper and pass as parameter for child pipeline. Could see only pipeline parameters visible in the Foreach snap.