JMS Active MQ - Failed to validate account

Hello Friends,
Need a help configuring JMS ActiveMQ account.
After trying multiple configuration settings still not able to validate account.
Please suggest solution. Find the attached configuration.
image


TCP connectivity test.

It seems there is an issue with name resolution. I’m not familiar with the Test-NetConnection script. It looks like you’re on Windows. As an experiment, does it work if you replace the hostname in the provider url with the IP address ?

java.naming.provider.url = tcp://192.168.0.12:61616

Alternatively, you could define a mapping for this hostname in your Windows host file. Not sure what versions of Windows you are running; maybe in C:\Windows\System32\drivers\etc\hosts

192.168.0.12 PC1J57TA

Thanks for update, I have already tried with replacing machine name with IP address/localhost/127.0.0.1 but its throwing same exception. Yes, I am trying on Window 10.
As suggested, I have tried DNS mapping option but it did not work.

Bummer. Definitely something to do with name resolution. If broker was down, or or port invalid, you would get a ConnectionException. Similarly, a SocketException would be raised if bad ip.

I’m able to reproduce locally if I use an invalid hostname. A valid hostname successfully validates (Linux).

You may want to file a support ticket. We have a lot of in-house expertise with Windows, just I don’t.

Hi Avinash:

Another thing to note is the IP address in your tcp connection test is a private non-routable address. I’m not sure of your SnapLogic configuration, but the Snaplex needs to be able to talk to this Active MQ broker. So, maybe that’s the issue. It looks like you ran the test on the same machine which isn’t a snaplex.

Oh Yes, Good point. Yes, I have run the pipeline on Snaplex and on the same machine as the installed JMS instance. Do I need to whitelist my local machine IP address within SnapLogic Cloud ?

The Snaplex will need to be able to access the host and port for wherever the Active MQ broker is running. I’m not sure of the level of access you have to your SnapLogic environment. There likely needs to be some additional configuration to access your machine, assuming it is accessible. I can try to help though!

I am using trial version of SnapLogic for hands on, How can i connect or share more details ?

Ok. There are limitations with a trial account. A Groundplex isn’t available, which means to access your Active MQ instance, your machine needs to be accessible over the Internet!

A Groundplex is a plex that is customer-managed, and so you could install other software on it, such as Active MQ. The Groundplex can be an on-premise instance or cloud-based instance. Cloudplexes, by contrast, are cloud-based and managed by SnapLogic.

It sounds like your experimenting with Active MQ. Many of the cloud providers allow you to spin up this service. I think Amazon’s MQ wraps Apache Active MQ.

I don’t want this to tarnish your impression of SnapLogic, because we really do have a big offering. I didn’t realize you were on a trial account.

Thanks so much