When executing pipeline it throws error with JMSWMQ2008

Hi,

i`m new to snaplogic,
i have a simple pipeline like:
File Reader --> JMS Producer

In File Reader i set a path to a csv file
In JMS Producer i set
Destination with a name of a queue like QUEUE_NAME1
Destination type : QUEUE
Messafe type: TEXT

When i run this pipeline it works without error.
So i suppose the file is sent to the queue.

In my organization the dev team say: the queue name is changed before sending the csv file.
So the name QUEUE_NAME1 is changed to QUEUE_NAME2 now

So i created a second pipeline to check whether the file cvs is arrived or not.
So i did this:
JMS Consumer–>Binary to document -->Mapper -->JMS Acknowlegde
in JMS Consumer i set:
Client_ID : name of the MQ manager
Destination: QUEUE_NAME2

When i run the second pipeline it throws error:
JMSCMQ0001: IBM MQ call failed with compcode ‘2’ (‘MQCC_FAILED’) reason ‘2085’ (‘MQRC_UNKNOWN_OBJECT_NAME’).
Caused by: com.snaplogic.api.ConfigurationException: An error occurred while creating the consumer

Caused by: com.ibm.msg.client.jms.DetailedInvalidDestinationException: JMSWMQ2008: Failed to open MQ queue ‘QUEUE_NAME2’.
JMS attempted to perform an MQOPEN, but IBM MQ reported an error.
Use the linked exception to determine the cause of this error. Check that the specified queue and queue manager are defined correctly.
Questions:
1-Is my first pipeline correct?
2-Is my second pipeline correct?
3- Is there a way to check if the queue name changed using java code only?
im not able to check the specified queue and queue manager are defined correctly. because i dont have permission level.
Thank you

Hi,
pipeline 1 looks correct, QUEUE_NAME1 queue will be created if it does not already exist.
pipeline 2’s error should have a reason code which may help confirm the cause. Have a look at
this case here.

How about downloading and importing in the sample pipeline in jms producer’s doc.
You can also install activeMq to test the snaps out as you will be the admin and can check everything there. They try them with IBM MQ?
I hope that helps,
Mina

Thank you Mina.
The error for pipeline2 seems to be an error queue manager name, i need to confirm inside my organization.
I tried activeMq
but i throws error 401 when opening 127.0.0.1:8161

see my cmd execution for activemq:
Im not able to copy all execution in cmd but i see this at begining

C:\activeMQ\apache-activemq-5.16.0-bin\apache-activemq-5.16.0\bin>activemq start*
at the end i saw this:

INFO | Apache ActiveMQ 5.16.0 (localhost, ID:S46493-53080-1594950562502-0:1) started
INFO | For help or more information please see: activemq.apache.org
INFO | ActiveMQ WebConsole available at 127.0.0.1:8161/
INFO | ActiveMQ Jolokia REST API available at 127.0.0.1:8161/api/jolokia/

You are welcome! If it says started, I think that looks good. Where exactly did you see the 401?Can you try http://localhost:8161/admin
on a browser and when it prompts you user/password is admin/admin.

Hi,
this url returns error 401
image

Browser issue?

very sorry for this, you are right it works in internet explorer

Hi Mina,
when you said:
“You can also install activeMq to test the snaps out as you will be the admin and can check everything there.”

So i have istalled activemq and it works with the following java code:
https://javainsider.wordpress.com/tag/jms-with-activemq-sample-example/

My producer and consumer work as intended in the website.

Now what is the relation with snaplogic?
How can i test my snaplogic with activemq?
Or maybe i misunderstood your tip.

part of java code:

public class Consumer {
// URL of the JMS server
private static String url = ActiveMQConnection.DEFAULT_BROKER_URL;
// default broker URL is : tcp://localhost:61616"

// Name of the queue we will receive messages from
private static String subject = “PASCAL-MESSAGE-1”;

Thank you

You can edit the jms consumer or producer snap>Account>Add Account>JMS account then fill out the fields as shown in my example below.


As long as the Groundplex node can access your queue, the snaps will as well.
My jcc node is on the same host so I used 127.0.0.1.

Thank you Mina, you can close this thread.

1 Like